#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z_\.-].[\.com|\.org|\.US]$"
Local $sString = "gmail.com" & @CRLF & _
"www@google" & @CRLF & _
"www.Coursera.org" & @CRLF & _
"web-address.com/homepage" & @CRLF & _
"My_Favorite-Blog.US"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")