#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\ id\ \|.)(([a-zA-Z0-9_]{8})-([a-zA-Z0-9_]{4})-([a-zA-Z0-9_]{4})-([a-zA-Z0-9_]{4})-([a-zA-Z0-9_]{12}))"
Local $sString = "Created a new subnet: " & @CRLF & _
"+-------------------+------------------------------------------------+ " & @CRLF & _
"| Field | Value | " & @CRLF & _
"+-------------------+------------------------------------------------+ " & @CRLF & _
"| allocation_pools | {"start": "10.42.42.2", "end": "10.42.42.254"} | " & @CRLF & _
"| cidr | 10.42.42.0/24 | | dns_nameservers | | | enable_dhcp | True | " & @CRLF & _
"| gateway_ip | 10.42.42.1 | " & @CRLF & _
"| host_routes | | " & @CRLF & _
"| id | 3eded702-2909-4515-bf74-7c7c2c7c96e3 | " & @CRLF & _
"| ip_version | 4 | " & @CRLF & _
"| ipv6_address_mode | | " & @CRLF & _
"| ipv6_ra_mode | | " & @CRLF & _
"| name | Atelier | " & @CRLF & _
"| network_id | 5d15b14c-1d39-48d5-8f48-0dfd68c98d47 | " & @CRLF & _
"| tenant_id | d3c17d0e8bd742ed939794a98991886f " & @CRLF & _
"| +-------------------+------------------------------------------------+" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")