import re
regex = re.compile(r"^((?:\d[+*]){0,49}\d)$", flags=re.MULTILINE)
test_str = ("1+2*3*8+0\n"
"9\n"
"9*9\n\n"
"the 99 character expression\n\n"
"1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+5*8\n\n"
"And these would not be valid:\n\n"
"1++1\n"
"12+1\n"
"2*25\n"
"1+\n"
"47\n"
"+\n"
"+1\n"
"11\n\n"
"100+ character length\n\n"
"1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+1*2+5*8+9")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")