$re = '/(?<![:0-9])(?P<hours>0?[0-9]|1[0-9]|2[0-3]):(?P<minutes>60|[0-5][0-9])(?::)?(?P<seconds>60|[0-5][0-9])?(?![:0-9]+\b)/';
$str = '/23:20:30';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);