package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[code][^\[]*\[\/code]`)
var str = `hi how are you [code]a=b+c[/code] again some text[code]c= 7*5[/code] Now some text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}