import re
regex = re.compile(r"(^|\b|\W)([PpРр9]+[UuÙÚÛÜùúûü]+[TtТт7]+[AaÀÁÂÃÄÅĄàáâãäåąАаДд4@ª]+)(s?)($|\b|\W)")
test_str = ("putá el que lo lea putaaaááÁÁaaaa:puta🍕. hijo-de-puuta: Esto es una putada. pupupuputa puto\n"
"Pu7äs every where.PUTAPuTAaaa-PûTA. Había unos cuantos hijos de puutaááaaó puta\n"
"lalal putaaa7 que te put@sñññ que (puta) eres. puta puta puta\n"
"Reputados réputaçión -> la é y la ç son \\W\n"
"Padre putativo\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")