$re = '/(?<=\/\* drapeDecalage: )(.*?)(?=px \*\/)/';
$str = 'body {
background: #000;
}
/* drapeDecalage: 10px */';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);