$re = '/\\\\doc(.*?)\\\\in/m';
$str = '\\doc doc1,doc2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);