$re = '/(.*a){14}/';
$str = 'aaaaaaaaaaaaaaaaaaaaaaa';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);