$re = '/\s+|(?<=\s)\'|\'(?=\s)|(?<=\w)([,.!?])/m';
$str = 'hello my name is \'joe.\' what\'s your\'s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);