import re
regex = re.compile(r"(?<!\w)(\s*)@embed(\s*\(.*\))([\w\W]*?)@endembed")
test_str = ("@extends('layouts/default')\n\n"
"@section('content')\n"
" <div class=\"row\">\n"
" <div class=\"col-md-6\">\n"
" @embed('components/box')\n"
" @section('title', 'Box title')\n"
" @section('content')\n"
" <h4>Haai</h4>\n"
" Box content\n"
" @stop\n"
" @endembed\n"
" </div>\n"
" <div class=\"col-md-6\">\n\n"
" @embed('components/box')\n"
" @section('title', 'Box2 title')\n"
" @section('content')\n\n"
" @embed('components/timeline')\n"
" @section('items')\n"
" @stop\n"
" @endembed\n\n"
" @stop\n"
" @endembed\n"
" </div>\n"
" </div>\n"
"@stop")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")