$re = '/([A-Za-z0-9_-]+?)[.]/m';
$str = '/src/components/App.vue';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);