$re = '/(\((?>[^()]|(?1))*\))/m';
$str = '( 10 + 9 ) * ( 13 *7 ) + ( 6 * ( 9 ) * 7 )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);