import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<nestedBrackets> \\[ [^][]* (?:\\g<nestedBrackets>[^][]*)*+ ] )\n"
+ ")\n\n"
+ "(?: # two possible entry points\n"
+ " \\G(?!\\A) # 1. contiguous to a previous match\n"
+ " | # OR\n"
+ " [^[]* \\[ # 2. all characters until an opening bracket\n"
+ ")\n\n"
+ "# all possible characters until \",\" or the closing bracket:\n"
+ "[^][\"]* # all that is not ] [ or \"\n"
+ "(?:\n"
+ " \\g<nestedBrackets> [^][\"]* # possible nested brackets\n"
+ " | # OR\n"
+ " \"(?!,\") [^][\"]* # a quote not followed by ,\"\n"
+ ")*+ # repeat as needed\n"
+ "\\K # remove all on the left from match result\n"
+ "(?:\n"
+ " \",\" # match the target\n"
+ " |\n"
+ " ] (*SKIP)(*F) # closing bracket: break the contiguity\n"
+ ")";
final String string = "[word:\"pla pla\",\"pla pla\",\"[other_word:\"pla pla\",\"[word:\"pla\",\"pla\"end word]\",\"pla pla\"end other_word]\",\"pla pla\",\"[word:\"pla\",\"pla\"end word]\"end word]\",\"";
final String subst = "|,|";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}