package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+?\d{1,4}?[-.\s]?\(?\d{1,3}?\)?[-.\s]?\d{1,4}[-.\s]?\d{1,4}[-.\s]?\d{1,9}`)
var str = `+79242051818`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}