using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sm)^""([a-z\d]+)""(?i)(?=(?:[^\n]*\n)+?""(?=\1"")(?-i)[A-Z\d]+"")";
string input = @"""hello"",""2018-11-19"",""unitelife""
""world"",""2018-11-09"",""unitelife""
""foo"",""2018-11-16"",""unitelife""
""bar"",""2018-10-05"",""unitelife""
""hello123"",""2018-09-06"",""unitelife""
""HELLO123"",""2018-11-18"",""unitelife""
""FOO"",""2018-11-20"",""unitelife""
""WOWMUCHHAPPY"",""2018-10-20"",""unitelife""
""suchjoy"",""2017-11-28"",""unitelife""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}