# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?sm)^(\"[a-z\d]+\")(?i)((?:[^\n]*\n)*[^\n]*)\n(?=\1)(?-i)\"[A-Z\d]+\"[^\n]*"
test_str = ("\"hello\",\"2018-11-19\",\"unitelife\"\n"
"\"HELLO\",\"2018-11-19\",\"unitelife\"\n"
"\"world\",\"2018-11-09\",\"unitelife\"\n"
"\"foo\",\"2018-11-16\",\"unitelife\"\n"
"\"bar\",\"2018-10-05\",\"unitelife\"\n"
"\"hello123\",\"2018-09-06\",\"unitelife\"\n"
"\"HELLO123\",\"2018-11-18\",\"unitelife\"\n"
"\"FOO\",\"2018-11-20\",\"unitelife\"\n"
"\"WOWMUCHHAPPY\",\"2018-10-20\",\"unitelife\"\n"
"\"suchjoy\",\"2017-11-28\",\"unitelife\"")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.