$re = '/^[\x00-\x20]+|[\x00-\x20]+$/';
$str = ' fjjj';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);