const regex = /(?:.*?(Constr1)+){3}.*?((Constr1)+)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.*?(Constr1)+){3}.*?((Constr1)+)', 's')
const str = `public class Constr1 { private int a; public Constr1 () { Constr1 Constr1 Constr1 //super(); a = 1; //super(); } }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}