$re = '/(?<=[a-z])([A-Z])|(?<=[A-Z])([A-Z][a-z])/';
$str = 'ShowXYZColour';
$subst = " \1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;