import Foundation
let pattern = #"^[^- '](?=(?![A-Z]?[A-Z]))(?=(?![a-z]+[A-Z]))(?=(?!.*[A-Z][A-Z]))(?=(?!.*[- '][- '.]))(?=(?!.*[.][-'.]))[A-Za-z- '.]{2,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Tyue' Tgshh
CxCx5C5C
STEVE SMITH
Stev3 Smith
STeve Smith
Steve SMith
Steve Sm1th
Steve G. Smith
d'Are to Beaware
Jo Blow
Hyoung Kyoung Wu
Mike O'Neal
Steve Johnson-Smith
Jozef-Schmozev Hiemdel
O Henry Smith
Mathais d'Arras
Martin Luther King Jr
Downtown-James Brown
Darren McCarty
An Ni
O. Henry McCarty
George De FunkMaster
Kurtis B-Ball Basketball
Ahmad el Jeffe
John Smith
'John Smith
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)