use strict;
my $str = '0.5An55.5Tik';
my $regex = qr/^\d*\.?\d+\K/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";