const regex = /^/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^', 'gm')
const str = `#Boligmarkedet i Vestby\$
Ifølge Statistisk sentralbyrå har Oslo opplevd et historisk flyttetap den siste tiden. Flere flytter ut av hovedstaden enn inn. Årsakene til utflyttingen er sammensatt og har med alt fra høye boligpriser til et ønske om å kunne gi barna sine andre oppvekstvilkår å gjøre. Uansett hva den viktigste årsaken er, kan man med sikkerhet si at utflyttere flest ender opp i de omkringliggende kommunene. Og da spesielt kommuner hvor man kan finne billigere boliger og andre oppvekstvilkår, samtidig som man slipper å si opp jobben i hovedstaden.
Selv om Vestby ikke er blant de aller nærmeste kommunene, er det mange som har fått til en slik løsning her. Det har sørget for at kommunen havner høyt på omsetningsstatistikken med et stabilt sterkt boligmarked. Og med ferdigstillelsen av Follobanen forventes det en ytterligere økning.
#Eiendomsmegler Vestby\$
Høy omsetning betyr mer jobb for eiendomsmeglerne. Og med mange konkurrerende meglerfirmaer i aksjon, vil man lett kunne overse de beste tilbudene. Ved hjelp av vår tjeneste blir det lettere for deg å få oversikt over tilbudene, slik at du kan ta en bedre beslutning.
#Vestby\$
Mellom Drøbak og Moss finner du en av Oslofjordens vakreste kystlinjer. Den tilhører den sydligste av Follo-kommunene, Vestby, og kan foruten flere strender og badeplasser skilte med en både historisk og levende kystkultur. Det er ikke for ingenting at Vestby kalles “kystperlen i Follo”.
Dette samspillet mellom natur og kultur er karakteristisk for kommunen for øvrig. I tillegg til de store utmarksområdene og tilhørende rekreasjonsmuligheter, har Vestby et godt utbygd tjenestetilbud, og den såkalte Sørkorridoren (E6, E18 og Østfoldbanen) sørger for god kommunikasjon til det sentrale Østlandet. Den planlagte Follobanen forventes dessuten å korte ned på reisetiden og øke kapasiteten mellom Vestby og Oslo markant.
Kommunen består av 19.969 innbyggere. Det er forventet en økning her i 2030 hvor prognosene til SSB sier at det nye forventede folketallet skal bli 20.553
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}