import re
regex = re.compile(r"(?:o|dp(?:\/[^/]+)?|gp\/product(?:\/[^/]+)?)\/([A-Z0-9]{10})", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("http://www.amazon.com/PlayStation-2-Console-Slim-Black/dp/B000TLU67W/ref=sr_1_4?ie=UTF8&qid=1389314719&sr=8-4&keywords=playstation+1\n"
"http://www.amazon.com/PlayStation-2-Console-Slim-Black/dp/B000TLU67W\n"
"http://www.amazon.com/gp/product/C0FF33CUP5\n"
"http://www.amazon.com/gp/product/CoffeeCups/C0FF33CUP5\n"
"http://www.amazon.com/o/C0FF33CUP5\n"
"http://www.amazon.com/dp/C0FF33CUP5\n"
"http://www.amazon.com/CoffeeCups/dp/C0FF33CUP5\n"
"http://www.amazon.com/CoffeeCups/dp/some-text/C0FF33CUP5\n"
"http://www.amazon.com/CoffeeCups/dp/B000TLU67W/ref=sr_1_4?ie=UTF8&qid=1389314719&sr=8-4&keywords=playstation+1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")