#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:google|yahoo)(?:\.com)?(*SKIP)(*F)|(?:(?!google|yahoo)\w)+\.com"
Local $sString = "" & @CRLF & _
" I like foobar.com" & @CRLF & _
" I like google.com and foobar.com" & @CRLF & _
" I like foobar.com and google.com" & @CRLF & _
" I like foobargoogle.com and googlefoobar.com" & @CRLF & _
" I like yahoo.com and foobar.com" & @CRLF & _
" I like foobar.com and yahoo.com" & @CRLF & _
" I like foobaryahoo.com and yahoofoobar.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" I like yahoo.com" & @CRLF & _
" I like foobaryahoo.com" & @CRLF & _
" I like google.com" & @CRLF & _
" I like foobargoogle.com" & @CRLF & _
" I like google.com and yahoo.com" & @CRLF & _
" I like foobargoogle.com and foobaryahoo.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")