$re = '/(an|a) (?P<Event>\S*)(with) (?P<Person>\S*) (in) (P<Loc>\S*)/';
$str = 'add an event with Hana Bouzid in Loc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);