$re = '/^(00|01|0011|0101|0110|1001|1010|1100)$/';
$str = '0000000100100011010001010110011110001001101010111100110111101111';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);