using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^>]+\d+(?=<)";
string input = @"<tbody><tr><th scope=""row"">Birthday</th><td>October 21</td></tr><tr><th scope=""row"">Marital Status</th><td>Single</td></tr></tbody>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}