re = /^(?!.*[*|\x22:<>[\]{}`()';@&$])/m
str = '/[*|\\":<>[\\]{}`()\';@&$]/
dwerfwefg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end