$re = '/^(([1-9]|[1-9][0-9]|1[0-4][0-9]|150)([,-](?=\d)|$))+$/mi';
$str = '1,10,1-150,25
0,1-10
1-10
,1
1,2,3-151,5
10,0-4,5
4
27-30
510
100-150
1-150
1,
2-
';
$subst = "$1\L$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;