use strict;
my $str = '08 21 2020 08:03:24 10.62.1.17 <AUDT:INFO> 2020-08-21 08:02:25 10.62.1.17 Passwordstate: A scheduled Account Heartbeat check successfully validated the password for the Active Directory account fakedomain\\FakeUser (\\Private Credentials\\dv\\Domain). Client IP Address = 10.62.1.17. PasswordListID = 32, PasswordID = 39';
my $regex = qr/<AUDT:INFO>.* Passwordstate:/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}