re = /^(?![\._]|.*?\.\..*|.*(?:\.|\.files|_files|-Dateien|_fichiers|_bestanden|_file|_archivos|-filer|_tiedostot|_pliki|_soubory|_elemei|_ficheiros|_arquivos|_dosyalar|_datoteke|_fitxers|_failid|_fails|_bylos|_fajlovi|_fitxategiak)$)[^!#%&*{}\:<>?\\\/|"]+$/i
str = 'the-f\\ile.doc'
# Print the match result
str.match(re) do |match|
puts match.to_s
end