re = /\${([^\s}]+)(?=})/m
str = 'This is a string with ${var1} and ${var2} and {var2}.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end