package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b(POST|GET)\s+([^?\s]+)`)
var str = `-- "GET /fss-w3-mtpage.php HTTP/1.1" 200 0.084 41 "-" "c110bc/1.0" 127.0.0.1:25001 0.084
-- "GET /m/firstpage/Services/getAll?ids=ABCVDFDS,ASDASBDB,ASDBSA&requestId=091fa2b4-643e-4473-b6d8-40210b775dcf HTTP/1.1" 200
-- POST /lastpage/Services/getAll?ids=ABCVDFDS,ASDASBDB,ASDBSA&requestId=091fa2b4-643e-4473-b6d8-40210b775dcf HTTP/1.1" 200`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}