package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0?4(12|14|16|24|26)[0-9]{7}`)
var str = `04121234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}