$re = '/^[a-zA-Z0-9-]+$/m';
$str = 'ABDWJ123123
ddwk92-13
dkwdj"-§/djwndj
wdlWKDO"0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);