# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\v\h+<{if \$data\.nowPage>1}>(?:\s+<div.*?<\/div>)+\s+<{\/if}>\R//g;t' <<< "<div class=\"pageContainer\">
<div class=\"pageBox\">
<{if $data.nowPage>1}>
<div class=\"pageArrow pageFirst\"><a href=\"?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=1\"><span class=\"icon arrow-first\"></span></a></div>
<div class=\"pageArrow pagePrev\"><a href=\"?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=<{$data.nowPage-1}>\"><span class=\"icon arrow-left\"></span></a></div>
<{/if}>
<{for $i=$data.nowPage-$data.pageFit to $data.totalPage}>
<{if $data.nowPage == ($i)}>
<div class=\"pageBtn active\"><a href=\"javascript:void(0);\"><{$i}></a></div>
<{else if $i>($data.nowPage+$data.pageFit)}>
<div class=\"pageMore\"><span class=\"icon moreIcon\"></span></div>
<{break}>
<{else if $i>0}>
<{if $i==$data.nowPage-$data.pageFit && $i>1}>
<div class=\"pageMore\"><span class=\"icon moreIcon\"></span></div>
<{/if}>
<div class=\"pageBtn\"><a href=\"?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=<{$i}>\"><{$i}></a></div>
<{else}>
<{/if}>
<{/for}>
<{if $data.nowPage<$data.totalPage}>
<div class=\"pageArrow pageNext\"><a href=\"?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=<{$data.nowPage+1}>\"><span class=\"icon arrow-right\"></span></a></div>
<div class=\"pageArrow pageLast\"><a href=\"?<{if !empty($data.years)}>y=<{$data.years}><{/if}><{if !empty($data.month)}>&m=<{$data.month}><{/if}>&p=<{$data.totalPage}>\"><span class=\"icon arrow-last\"></span></a></div>
<{/if}>
</div>
</div>"