$re = '/(?<=A)(\d{7,8})(?=00)/m';
$str = 'eg: Input: ABC12345678CRP1234567F2801209A1234567800<<<33
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);