$re = '/(?:auto">)?(.+)(?=(?:\n|<\/pre>))/m';
$str = 'auto">http://url-one.com
http://url-two.com
http://url-three.com
http://url-four.com
http://url-five.com</pre>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);