re = /^(\/?(([a-zA-Z0-9\-\_]+)|(\{[a-zA-Z][a-zA-Z0-9]*\}))\/?)*$/m
str = 'test/{a}/{b}
/some-text/{a}/{a}/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end