re = /"([^"]+)"|~\w+(?:-\w+)*~/m
str = 'Ayala NOT ("Ayala Station" OR "Ayala Branch" OR "Joey Ayala")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end