$re = '/(?:,| )(?:HD|\(HD\))/m';
$str = 'Superman
Superman HD
Superman (HD)
Superman,HD
Superman,(HD)
Hands on
Hands, on';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);