import re
regex = re.compile(r"(?:^(R)\|(\d+)\|\^*([^|]*)\|([^|]*)\|(?:([^|]*)\|)?.*$)|(?:^(P)\|(\d+)\|\|(\d+).*$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("P|1||322061||^|||U \n"
"O|1||138||||||||||||O \n"
"R|1|^^^BE(B)||mmol/L||C||||||20150819144937 \n"
"R|2|^^^BEecf||mmol/L||C \n"
"R|3|^^^Ca++|1.17|mmol/L \n"
"R|4|^^^Ca++(7.4)||mmol/L||C \n"
"R|5|^^^HCO23-||mmol/L||C \n"
"R|6|^^^HCO3std||mmol/L||C \n"
"R|7|^^^K+|5.0|mmol/L \n"
"R|8|^^^Na+|140|mmol/L \n"
"R|9|^^^SO2c||%||C \n"
"R|10|^^^TCO2||mmol/L||C \n"
"R|11|^^^THbc||g/dL||C \n"
"R|12|^^^Temp|37.0|C\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")