$re = '/^.{9}(.*?)(?=-)/';
$str = '10680756-1000-RET-';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);