const regex = /std::shared_ptr\h*<(?'type'[A-Z:_a-z<>]*)>\h*\(\h*new\h*\k'type'(?'args'\([^()]*+(?:(?&args)[^()]*+)*+\))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('std::shared_ptr\\h*<(?\'type\'[A-Z:_a-z<>]*)>\\h*\\(\\h*new\\h*\\k\'type\'(?\'args\'\\([^()]*+(?:(?&args)[^()]*+)*+\\))', '')
const str = `tf->get_TextState()->set_TextMatrix(std::shared_ptr<DOM::Matrix>(new DOM::Matrix(m->get_M11(), -m->get_M12())));`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}