$re = '/std::shared_ptr\h*<(?\'type\'[A-Z:_a-z<>]*)>\h*\(\h*new\h*\k\'type\'(?\'args\'\((?>[^()]|(?&args))*\))/';
$str = 'tf->get_TextState()->set_TextMatrix(std::shared_ptr<DOM::Matrix>(new DOM::Matrix(m->get_M11(), -m->get_M12())));';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);