const regex = /\b(\w+)\s[\s\w]*\1/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w+)\\s[\\s\\w]*\\1', '')
const str = `Palavra1 Palavra2 Palavra1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}