re = /from:\s*"+\s*bob*+\s*"\s*,\s*to:\s*"\s*[a-zA-Z]*\s*"\s*,\s*content:\s*"\s*[a-zA-Z]*\s*"\s*/m
str = 'from: "bob", to: "Receiver", content: "Payload"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end