using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.+\/\/).*(@.*$)";
string substitution = @"\1user:pass\2";
string input = @"http_proxy=""http://QQ@127.0.0.1:8080/""
http://test1:test2@127.0.0.1:8080/
http_proxy=""http://QQ@127.0.0.1:8080/
http://@127.0.0.1:8080/""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}