$re = '/[^?\/]+(?=\?|$)/';
$str = '/foo/bar/image.jpg?x=1&y=2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);